关于BurpSuite高于2.0版本出现的各种问题解决方法

/ 0评 / 6

最近一段时间想试一下BurpSuite新版,但是出现了各种问题,我就说我遇到的最多的两个问题的解决方法:

提前说明:Java环境升级请慎重,如果你电脑还有其他需要运行Java的工具,可能就会无法使用了,比如:冰蝎jar启动版、菜刀的jar启动版、Shiro的jar版,对此,我正在寻找能够兼容新版Burp和其他Java工具的Java版本。——答:艹!没有!

1、在网上下载的各种破解包进行破解时,BurpSuite的jar程序总是无法启动,但是使用小于等于2.0版本的BP就可以启动,这个这个其实是Burp的新版对于java环境的适配问题,只要下载安装最新版的java环境就好,另,如果你和我一样用的BurpSuite-2020.11.3版本,只需无脑安装最新的java环境就行:

BurpSuite下载地址:点此跳转

Oracle官网:点此跳转

P.S. JAVA的官方下载已经不再提供单独的页面进行下载了,得进入oracle的官网后注册账号,才能进行下载,或者找其他离线资源

2、BurpSuite大于2.0的版本在Windows操作系统上使用时,都有的一个问题——光标偏移(错位)的问题的解决方式:

大于2.0的BP我都下载破解版试用过,但是由于光标错位的问题,都放弃了,今天,我终于找到了解决方法。

我的使用环境:

BurpSuite:2020.11.3

Java环境:Java-15

操作系统:Win10

电脑厂家:联想 小新 - Pro13

发生错位时,一般大概是这样的:

解决方法有两个,都与字体的调整有关:

1、使用者不需要看中文的情况下,在设置里将Font参数调整成英文就行了:

优点:不需要考虑Size参数,只要是英文字体,随便调就行;

缺点:中文无法正常显示了。

2、需要中文的情况下,将Font参数调整至中文字体后,就需要调整Size参数了,否则就会出现如下情况:

1)不调整Size参数,或者Size参数不合适:

2)当Size参数合适了,就会显示正常,比如我的调整到15和16就正常了,超过16就会向后偏移:

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注